Prometheus writes in prod-eu-west-3 are degraded

Incident Report for Grafana Cloud

Update

We have deployed mitigation and seen improvement in write failures over the past week. We are still seeing intermittent spikes in latency and continue to monitor.
Posted Apr 14, 2026 - 20:11 UTC

Update

We are still seeing intermittent issues and continue to seek a resolution
Posted Apr 08, 2026 - 20:32 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 02, 2026 - 21:38 UTC

Update

We are continuing to monitor this through the weekend.
Posted Mar 27, 2026 - 21:05 UTC

Update

We are continuing to monitor the previously impacted environments.
Posted Mar 26, 2026 - 17:45 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2026 - 12:04 UTC

Update

We are continuing to investigate this issue.
Posted Mar 25, 2026 - 21:35 UTC

Investigating

The metric writes issue reported in https://status.grafana.com/incidents/gfshj17lxj5z is still ongoing.

Our Engineering team is actively investigating this and we will provide further updates as our investigation progresses.
Posted Mar 25, 2026 - 14:11 UTC
This incident affects: Grafana Cloud: Prometheus (Azure Netherlands - prod-eu-west-3: Ingestion).