Elevated latency in prod-us-east-0 cluster.

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 17:58 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Jun 02, 2025 - 15:48 UTC

Investigating

We're observing an elevated latency in prod-us-east-0 cluster for Hosted Metrics service. We're currently investigating the issue.
Posted Jun 02, 2025 - 14:56 UTC
This incident affected: Grafana Cloud: Prometheus (AWS US East - prod-us-east-0: Querying, AWS US East - prod-us-east-0: Ingestion).