Failures to ingest otel metrics .net apps

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 18:51 UTC

Monitoring

A fix is currently being rolled out, and has already rolled out to prod-eu-central-0 and prod-au-southeast-1

prod-eu-central-0: around 5:05 pm UTC
prod-au-southeast-1: around 4:50 pm UTC
Posted Sep 18, 2025 - 17:56 UTC

Update

Current Update: Users of the OpenTelemetry .NET SDK might face protocol errors when pushing directly to Grafana Cloud without the use of a collector

We are leaving the previous update posted for transparency, but please note that there is currently no known workaround.
Posted Sep 18, 2025 - 17:17 UTC

Update

Note: A viable workaround is to use collectors on r134
Posted Sep 18, 2025 - 14:11 UTC

Investigating

Users of OTel collector v0.133 might face protocol errors from .net applications leading to failures writing metrics to Grafana Cloud
Posted Sep 18, 2025 - 13:01 UTC
This incident affected: Grafana Cloud: Prometheus (AWS Australia - prod-ap-southeast-2: Ingestion, AWS Brazil - prod-sa-east-1: Ingestion, AWS UAE - prod-me-central-1: Ingestion, AWS Japan - prod-ap-northeast-0: Ingestion, GCP India - prod-ap-south-0: Ingestion, GCP UK - prod-gb-south-0: Ingestion).