Grafana Cloud: Migration Assistant - degraded performance

Incident Report for Grafana Cloud

Resolved

We have implemented a fix and verified it with a load test.
Posted May 26, 2025 - 02:50 UTC

Monitoring

A fix is scheduled for release in an upcoming Grafana update, expected in late May or early June.
Posted May 20, 2025 - 21:07 UTC

Update

We are continuing to investigate this issue.
Posted May 15, 2025 - 13:46 UTC

Investigating

The team is aware of issues with migrating large numbers of resources and is working on a fix
Posted May 15, 2025 - 13:46 UTC
This incident affected: Grafana Cloud: Migration Assistant.