SLO Performance Degradation

Incident Report for Grafana Cloud

Resolved

Engineering has released a fix and as of 18:45 UTC, customers should no longer experience issues with creating, editing, updating, or deleting SLOs.

We continue to observe a continued period of recovery. At this time, we are considering this issue resolved. No further updates.
Posted May 19, 2025 - 19:17 UTC

Investigating

As of 17:55 UTC, we became aware of a performance issue to our Cloud App Platform. Users experiencing this issue may be unable to create, edit, update, or delete SLOs.

Engineering is actively engaged and assessing the issue. We will provide updates accordingly.
Posted May 19, 2025 - 18:41 UTC
This incident affected: Grafana Cloud: Hosted Grafana (GCP US Central - prod-us-central-4).