We continue to observe a continued period of recovery. At this time, we are considering this issue resolved. No further updates.
Posted May 12, 2025 - 21:35 UTC
Monitoring
As of 20:32 UTC, customers should no longer experience any issues with the Private Datasource Connection (PDC) Agent. We will continue to monitor for recurrence and provide updates accordingly.
Posted May 12, 2025 - 21:06 UTC
Identified
As of 18:52 UTC, we were alerted to an issue with the Private Datasource Connect (PDC) Agent. Users experiencing this issue may have encountered a "Connection Status Not Available" error for the duration for any PDC Agent configured in their environment. Additionally, users may have experienced 504 Gateway Timeout Errors and/or dashboards that query data from PDC agents failing to load data.
Posted May 12, 2025 - 21:06 UTC
This incident affected: Grafana Cloud: Private Datasource Connect (PDC) (AWS US East - prod-us-east-0).