We can confirm full recovery on our Grafana hosted services (since ~9:50 UTC), we have continued monitoring them to ensure no further impact is experienced.
Posted Oct 20, 2025 - 10:53 UTC
Monitoring
Our infrastructure provider has indicated recovery of the services, we can confirm this, and we are currently monitoring for full availability of the services. Additionally, we have identified the affected services, and have implemented actions to help mitigate impact.
Impacted Services include: - AWS customers can’t subscribe to Grafana Cloud through the AWS marketplace - Unable to pull docker images from Grafana repository - K6: Test runs disrupted across all AWS load zones - Issues to open ticket to Grafana Support - IRM: Slack and SMS/Call notifications missing
Posted Oct 20, 2025 - 10:14 UTC
Identified
Since 8:15 UTC we have been experiencing issues on different services from Grafana Cloud, due to problems on one of our infrastructure providers. We are investigating full impact on Grafana Services and applying measurements to palliate the disruptions in our services.
Posted Oct 20, 2025 - 09:50 UTC
This incident affected: Website & Support (Grafana.com, Support Tickets), Grafana Cloud: k6 (Cloud Test Runs), and Grafana OnCall.