Loki - Slow Queries

Incident Report for Grafana Cloud

Resolved

We continue to observe a continued period of recovery. At this time, we are considering this issue resolved. No further updates.
Posted Jun 11, 2025 - 21:57 UTC

Monitoring

Engineering has released a fix and as of 20:45 UTC, customers should no longer experience slow log queries. We will continue to monitor for recurrence and provide updates accordingly.
Posted Jun 11, 2025 - 20:45 UTC

Investigating

As of 20:23 UTC, we became aware of an issue with Loki query speeds. Users experiencing this issue may encounter slow query speeds for logs. Write performance should not be affected.

Engineering is actively engaged and assessing the issue. We will provide updates accordingly.
Posted Jun 11, 2025 - 20:32 UTC
This incident affected: Grafana Cloud: Loki (AWS US East - prod-us-east-0).