Private Datasource Connect - New Agents Failing To Get SSH Certificates Signed

Incident Report for Grafana Cloud

Resolved

We continue to observe a continued period of recovery. At this time, we are considering this issue resolved. No further updates.
Posted Jun 03, 2025 - 16:12 UTC

Monitoring

As of 13:34 UTC, our engineering team became aware of an issue with PDC Agents failing to get new SSH certificates signed. Existing PDC Agents will continue working until the connection is terminated.

Engineering has released a fix and as of 14:58, customers should no longer experience issues with new PDC Agent SSH certificates. We will continue to monitor for recurrence and provide updates accordingly.
Posted Jun 03, 2025 - 15:23 UTC
This incident affected: Grafana Cloud: Private Datasource Connect (PDC) (AWS Germany - prod-eu-west-2).