Private Datasource Connect API connectivity issues

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 12:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 22, 2025 - 12:06 UTC

Update

We are continuing to investigate this issue.
Posted Oct 22, 2025 - 11:44 UTC

Investigating

We are experiencing issues with Private Datasource API connectivity in some regions.
The API hosts are not reachable.
We are actively investigating this matter.
Posted Oct 22, 2025 - 11:24 UTC
This incident affected: Grafana Cloud: Private Datasource Connect (PDC) (AWS Indonesia - prod-ap-southeast-2, AWS Switzerland - prod-eu-central-0, AWS UAE - prod-me-central-1).