Investigating elevated database load in AWS Germany

Incident Report for Grafana Cloud

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 13:51 UTC

Monitoring

A fix has been implemented and we have been seeing recovery to the affected region. We will continue to monitor.
Posted Sep 09, 2026 - 12:44 UTC

Investigating

We are investigating elevated database load affecting infrastructure supporting a subset of Grafana Cloud instances in the AWS Germany region (prod-eu-west-4).

Affected users may experience slow responses when accessing Grafana. We will provide an update as more information becomes available.
Posted Sep 09, 2026 - 11:27 UTC
This incident affected: Grafana (AWS Germany - prod-eu-west-4).