High Latency in prod-us-east-2

Incident Report for Grafana Cloud

Monitoring

We have observed latency return to normal levels, and we will continue to monitor this incident.
Posted Sep 08, 2026 - 17:04 UTC

Investigating

We are currently investigating an issue causing high latency for deployments in the prod-us-east-2 cluster.
Posted Sep 08, 2026 - 16:14 UTC
This incident affects: Grafana (AWS US East - prod-us-east-2).